If you have a support question or comment, click the Post New Topic link below.
Current Version: 3.9.5 | Sytist Manual | Sytist Articles 

Warning: Ob_start(): Function 'ob_gzhandler'

 
Please log in or Create an account to post or reply to topics.
 
Yann Queniart
121 posts
Thu May 20, 21
2:22 PM
Hi,

When I switch from PHP 7.3 to PHP 7.4 I have this error.

Warning: ob_start(): function 'ob_gzhandler' not found or invalid function name in /volume1/Web/public_www/sy-admin/index.php on line 10 Warning: Cannot modify header information - headers already sent by (output started at /volume1/Web/public_www/sy-admin/index.php:198) in /volume1/Web/public_www/sy-admin/admin.login.php on line 63

Warning: ob_start(): function 'ob_gzhandler' not found or invalid function name in /volume1/Web/public_www/sy-admin/index.php on line 10 Warning: Cannot modify header information - headers already sent by (output started at /volume1/Web/public_www/sy-admin/index.php:198) in /volume1/Web/public_www/sy-admin/admin.functions.php on line 510

Don't find where is the problem, any solution please ?

Best regards
Tim - PicturesPro.com
13572 posts
admin
Fri May 21, 21
8:12 AM
You can either contact your host and tell them " function 'ob_gzhandler' not found ".

Or do this for a workaround, edit the sy-config.php file that is in the main Sytist folder on your website through the file manager in your hosting control panel.

Add this line of code on a line toward the top of the file after the <?php

$setup['ob_start_only'] = true;
Edited Fri May 21, 21 8:12 AM by Tim - PicturesPro.com
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Marco B
35 posts
Fri May 21, 21
8:30 AM
hello Yann Queniart, I take advantage of your post to ask you something.
can you confirm that with php 7.3 everything is ok with sytist? I ask because I am still with an older version and I am afraid to update it since it works.
thank you
 
 
 
 
 
Tim - PicturesPro.com
13572 posts
admin
Fri May 21, 21
8:34 AM
Sytist is compatible up to PHP 7.4.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Yann Queniart
121 posts
Sat May 22, 21
1:58 AM
Hi Marco,

Yes that work with PHP 7.3. I know Sytist is compatible with PHP 7.4.

I host myself on Synology NAS and webstation and I have no control on the compilation of PHP and his extension (but it is so easy to manage ^^).

Tim, that work perfectly with this code line. I have enable zlib compression, in php documentation they say it is preferable to use lib.output_compression over ob_gzhandler
Loading more pages
Loading more pages

Sign up for email promotions.

Your information is safe with us and won't be shared.

Thank you for signing up!

 
©2003 - 2021 Grissett, LLC. All Rights Reserved.

By continuing to browse or by clicking Accept Cookies, you agree to the storing of cookies on your device necessary to provide you with the services available through our website.

    Accept   Privacy & Cookie Policy
Loading More Photos
Scroll To Top
Close Window
Loading
Close