If you have a support question or comment, click the Post New Topic link below. Sytist Manual | Sytist Articles | Facebook Page.

Logging In Issue

 
Please log in or Create an account to post or reply to topics.
 
Larry McHugh
Sun Nov 12, 17
11:52 AM
I'm locked out of the Admin. I've tried doing a password reset request but I'm not getting any email response.

Also, what is the highest version of PHP that works with Sytist? I'm need to get my server to meet PCI compliance.
Tim - PicturesPro.com
admin
Mon Nov 13, 17
5:50 AM
Check your spam folder for your reset email.

But when you try to log in, does it say that information is incorrect or does it just seem to refresh the page? If it seems to just refresh the page with no message, it could be possible you are out of space on your hosting account.

Sytist is compatible with PHP 7.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Larry McHugh
Mon Nov 13, 17
10:35 AM
I checked the spam. No email.

Some additional information....

We host our site -- there is no issue with space.

The page does refresh after saying that the login is invalid (I know it is valid -- I have tried other user logins as well). I do get the page asking to reset password. That appears to not work either.

I have another user with admin privileges that can't login either. Customers can't as well, they just get a spinning wait cursor.

We are currently using PHP v5.6.16.

I did look at the database through MySQL Workbench (I am a programmer and DB admin as well). I can see the second admin account in the "admin" table, as well as the other users that have minimal privileges, but I see no entry for my account. Needless to say we can't login to add new customers or access their accounts.

Could it be a bad setting in PHP? These are my current settings:

[WebPIChanges]
error_log=C:WindowstempPHP5616_errors.log
upload_tmp_dir=C:Windowstemp
session.save_path=C:Windowstemp
cgi.force_redirect=0
cgi.fix_pathinfo=1
fastcgi.impersonate=1
fastcgi.logging=0
max_execution_time=300
date.timezone=America/New_York
extension_dir="C:Program Files (x86)PHPv5.6.16ext"

[ExtensionList]
extension=php_mysql.dll
extension=php_mysqli.dll
extension=php_mbstring.dll
extension=php_gd2.dll
extension=php_gettext.dll
extension=php_curl.dll
extension=php_exif.dll
extension=php_xmlrpc.dll
extension=php_openssl.dll
extension=php_soap.dll
extension=php_pdo_mysql.dll
extension=php_pdo_sqlite.dll
extension=php_imap.dll
extension=php_tidy.dll
;extension=php_pdo_sqlsrv.dll
;extension=php_sqlsrv.dll

[PhotoCart]
SMTP = localhost
smtp_port = 25
sendmail_from = orders@marklawrencephotographers.com

If possible, I would like to avoid starting from scratch with a blank database. Could you walk me through what to look for in MySQL. I can make the changes if necessary.

You can contact me at 603-882-0116. If you would like me to call you let me know.


Tim - PicturesPro.com
admin
Mon Nov 13, 17
11:32 AM
It won't be the database. For some reason it is unable to set the PHP session.

Check your error log and see if there is anything new related to this in it.

And are you positive that is the PHP version you are using? You can download this zip file, unzip it and upload the phpinfo.php file to the server and view it in your browser and it will show the PHP version.
https://www.picturespro.com/sy-misc/download/phpinfo.zip
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Larry McHugh
Mon Nov 13, 17
11:51 AM
By error log I'm assuming you mean the PHP error log. The last error messages were in August of last year. Nothing current.

I'm sure about the version. PHP is not my strong point. Where in Sytist is the session set? Could it be a folder permissions issue?
Tim - PicturesPro.com
admin
Mon Nov 13, 17
12:30 PM
Yes the PHP error log.

Do you recall if you had to change any folder or file permissions when you installed Sytist? If so, perhaps the permissions have changed.

The sy-phpsessions is the folder that stores those sessions by default, unless you changed it.

But edit the sy-config.php file that is in the main Sytist folder.

Look for this line:

ini_set('session.save_path', $setup['path']."/sy-phpsessions");

If it is there, remove it and save then try to log in.

If that doesn't do it, you can email me FTP info so I can look at the files.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Larry McHugh
Mon Nov 13, 17
12:51 PM
Not sure about if I changed file permissions when I installed. I know I haven't recently change them.

The ini_set was in the sy-config.php file. I commented it out and tried to log in. No luck.

I set up an account for you on our FTP site to access the Sytist folder. Your credentials are: Username: ***** Password: *****. Please note we use FTP over TLS. Please let me know if you have any problems.

Thanks,

Larry.
Edited Mon Nov 13, 17 12:56 PM by Tim - PicturesPro.com
Tim - PicturesPro.com
admin
Mon Nov 13, 17
1:07 PM
I made the change to your sy-config.php file commenting out that line above

// ini_set('session.save_path', $setup['path']."/sy-phpsessions");

And you can now login.

HOWEVER, the problem is the files/folders are no longer writable which means, you can't create new pages and probably can't upload photos.

So something changed on the server to cause this. On linux servers, its called permission. I believe on a windows server its called security. You need to find a way to make the files and folders world writable I belive it is called.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Larry McHugh
Mon Nov 13, 17
2:10 PM
On Windows it is called "Security". Which files and folders should I make writable?
Larry McHugh
Mon Nov 13, 17
2:49 PM
I was able to get in. Thanks.

When I upload images I get a HTTP 413 Request entity too large. How do I resolve that?
Larry McHugh
Mon Nov 13, 17
3:21 PM
I uploaded a photo. The thumbnail image is not being shown, only the description of the image below it. The description itself is very narrow or compressed. What's the cause?
Larry McHugh
Mon Nov 13, 17
3:23 PM
Images that were uploaded prior to this "crash" event are displaying perfectly.
Larry McHugh
Mon Nov 13, 17
3:34 PM
Forget the HTTP 413 question.
Tim - PicturesPro.com
admin
Tue Nov 14, 17
6:12 AM
Your sytist folder and all files/ folders inside it should be set to writable. That is probably why you can't upload photos.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Larry McHugh
Tue Nov 14, 17
9:11 AM
All set. Thanks for the help.
Loading more pages
Loading more pages
Sign up for email promotions.
Your information is safe with us and won't be shared.
Thank you for signing up!
 
©2003 - 2017 Grissett, LLC. All Rights Reserved.
Loading More Photos
Scroll To Top
Close Window
Loading
Close