To post a new support question, click the Post New Topic button below.
Current Version: 4.8.3 | Sytist Manual | Common  Issues | Feature Requests

Please log in or Create an account to post or reply to topics.
You will still receive notifications of replies to topics you are part of even if you do not subscribe to new topic emails.

Sytist 4.7 Upgrade Now Available

16,043 posts (admin)
Wed Nov 29, 23 4:48 AM CST

View detailed information about this update in the changelog here.

The major change in the upgrade is  a new redeveloped way for customers to select images for their collections (packages)

The new way adds a horizontally scrolling container at the bottom of the screen that has spots for the products in the collection. After the collection is added to cart, this area appears and the customer will tap/click the blank areas to select the photo they are viewing for that product.

This is the same for all devices but it makes it much easier for customers to select photos on mobile.

See this article for more information on this.

Other changes as well. View the change log here.

How to update:
The first time each day you log into the admin it will check for the update and if one is available you will have a notice in blue on your Sytist admin homepage

If you have already logged into your admin today, then you won't get the notice until tomorrow. Or you can click Settings in the main menu then UNDERNEATH the left menu click check for update.

Tim Grissett, DIA - PicturesPro.com
My Email Address: info@picturespro.com
J
6 posts
Wed Nov 29, 23 8:26 AM CST

I just updated and the area does not appear until I refresh the page. When the collection is selected, It brings me back to the initial picture but the area does not appear. I must scroll through other pictures or refresh the page for it to appear.

Is there a way to fix this?


Thanks!

26 posts
Wed Nov 29, 23 8:33 AM CST

Hello,

I just tested the new collections update feature (upgrade 4.7) from a number of galleries that I have active on my website now and most of the photos are not showing up in the preview screen at the bottom of the page in the gallery or even on "The View" cart screen.  The photos that have the option to change the background are showing up, but almost every other photo will not.  Does the photo have to be in an exact 8x10 size?  Many photos in my galleries have a box attached to the bottom of the 8x10 photo with some instructions, so most of the photos in my galleries are not 8x10, but more like 8x12 or so.  Any help would be very appreciated because I know that my clients will completely freak out during ordering if they can't view the photos they add to their order.


Thanks,
Lori S.

Attached Photos

Lori Seals - Lori A. Seals Photography
16,043 posts (admin)
Wed Nov 29, 23 8:36 AM CST
James Hajjar wrote:

I just updated and the area does not appear until I refresh the page. When the collection is selected, It brings me back to the initial picture but the area does not appear. I must scroll through other pictures or refresh the page for it to appear.

Is there a way to fix this?


Thanks!

It sounds like you perhaps didn't do the last step of the upgrade. Go to Design -> Edit My Theme and then just save the theme. See if that fixes it.

If not, email me a link to a gallery with password if needed.

Tim Grissett, DIA - PicturesPro.com
My Email Address: info@picturespro.com
16,043 posts (admin)
Wed Nov 29, 23 10:06 AM CST
Lori Seals wrote:

Hello,

I just tested the new collections update feature (upgrade 4.7) from a number of galleries that I have active on my website now and most of the photos are not showing up in the preview screen at the bottom of the page in the gallery or even on "The View" cart screen.  The photos that have the option to change the background are showing up, but almost every other photo will not.  Does the photo have to be in an exact 8x10 size?  Many photos in my galleries have a box attached to the bottom of the 8x10 photo with some instructions, so most of the photos in my galleries are not 8x10, but more like 8x12 or so.  Any help would be very appreciated because I know that my clients will completely freak out during ordering if they can't view the photos they add to their order.


Thanks,
Lori S.

The update should not have had an effect on the images in the view cart.

Email me the link to the gallery with password if needed so I can see.

Tim Grissett, DIA - PicturesPro.com
My Email Address: info@picturespro.com
26 posts
Wed Nov 29, 23 10:23 AM CST
Hi Tim,

Thank you for your reply!  I just emailed the information to you so you can take a look and see if you get the same issues that I'm having.

Thanks again and I appreciate the help!
Lori Seals - Lori A. Seals Photography
26 posts
Wed Nov 29, 23 11:06 AM CST

Hi Tim,

Whatever you did worked perfectly!  Everything is showing up now where it should be.  Thank you again for your quick reply and for your help...it is greatly appreciated!  

--Lori S.

Lori Seals - Lori A. Seals Photography
J
6 posts
Wed Nov 29, 23 12:31 PM CST
Tim - PicturesPro.com wrote:

The update should not have had an effect on the images in the view cart.

Email me the link to the gallery with password if needed so I can see.

Just sent you an email. Thanks!

129 posts
Wed Nov 29, 23 3:14 PM CST
Tim - PicturesPro.com wrote:

It sounds like you perhaps didn't do the last step of the upgrade. Go to Design -> Edit My Theme and then just save the theme. See if that fixes it.

If not, email me a link to a gallery with password if needed.

Hi Tim

I also have the same issue when adding a package, I need to refresh the page to have the package managing area visible. I did the last CSS step and even some theme edits after that. Shall I mail you a page with this issue?

L
370 posts
Wed Nov 29, 23 9:21 PM CST

oh man - so freaking excited, just uploaded my last gallery of the year this morning too, so still a chance to see it in action - update appears to have gone well - thanks Tim!

16,043 posts (admin)
Thu Nov 30, 23 3:48 AM CST
Marcel Otterspeer wrote:

Hi Tim

I also have the same issue when adding a package, I need to refresh the page to have the package managing area visible. I did the last CSS step and even some theme edits after that. Shall I mail you a page with this issue?

4.7.1 is out now that will fix it. 

If you have already logged into your admin today and not seeing the update available, you can click Settings in the main menu then UNDERNEATH the left menu click check for update.

Tim Grissett, DIA - PicturesPro.com
My Email Address: info@picturespro.com
T
353 posts
Fri Dec 01, 23 5:26 AM CST

Thanks Tim for catching this one.  

We haven't updated yet, but looking at the changelog, this:

  • Fixed JPG images mixed in a Green Screen gallery showing broken images when added to a collection.

would have caused issues, as we regularly mix .jpg and .png alpha channel images in the same gallery.

Edited Fri Dec 01, 23 7:32 AM by Trailboy
C
18 posts
Fri Dec 01, 23 11:40 AM CST

My client is getting this error when trying to select photos - and I am too when I try.

Attached Photos

16,043 posts (admin)
Fri Dec 01, 23 11:53 AM CST

Are you adding the collection to cart from favorites or the gallery?

Tim Grissett, DIA - PicturesPro.com
My Email Address: info@picturespro.com
C
18 posts
Fri Dec 01, 23 11:56 AM CST

It gives me the error for both the gallery and favorites.

16,043 posts (admin)
Fri Dec 01, 23 12:02 PM CST

Email me a link to a gallery with password if needed so I can see it. I can't duplicate that.

Tim Grissett, DIA - PicturesPro.com
My Email Address: info@picturespro.com
C
18 posts
Fri Dec 01, 23 12:12 PM CST
Tim - PicturesPro.com wrote:

Email me a link to a gallery with password if needed so I can see it. I can't duplicate that.

Emailed you! Thank you!

T
353 posts
Fri Dec 01, 23 1:57 PM CST

Hi Tim.  

More of a possible future feature request, but given the clearer method of adding images to packages, could we have a button that that offers customers to 'fill your whole pack with this one image'?


We do get a few support requests where they get stuck at the 'Ooooops, hold on' page.

T
353 posts
Fri Dec 01, 23 1:59 PM CST

Attached image

Attached Photos

L
370 posts
Fri Dec 01, 23 10:53 PM CST

Hello,  I am getting this for the 2nd child order ( first child's order being complete and then the client is going back into gallery for the 2nd order, no other items in cart )

I have logged in as client and got the same error and managed to get to cart/checkout and take payment over the phone ( she will "heart" her print selection for me )

I have now logged in for a ficticious "third child" ( using another kid's code ) and getting the same error.




Attached Photos

L
370 posts
Fri Dec 01, 23 11:03 PM CST

I have now just logged in as another customer using a completely different child code and getting the same error - could it be a cookies thing - as I have already used this computer to place an order, I cannot place another order?

I use the -dash- style passcoding if that is relevant.


16,043 posts (admin)
Sat Dec 02, 23 4:15 AM CST
Leanne, Are you redeeming a print credit or adding a collection to cart?

Can you post or email me a screenshot of the settings of the collection?

Edited Sat Dec 02, 23 11:54 AM by Tim - PicturesPro.com
Tim Grissett, DIA - PicturesPro.com
My Email Address: info@picturespro.com
This reply was deleted.
26 posts
Tue Dec 05, 23 8:43 AM CST

A couple of things I just noticed. . .

I sell "Traditional Style" and "Premium Style" photos to my clients.  The "Premium Style" photos have a different price list attached to them and prompt for an upgrade fee to be added to their shopping cart first before it unlocks the "Premium Style" shopping cart/price list in their gallery.  

My 1st Issue:  When I'm logged in as a client and add photos to a "Traditional Style" collection in a gallery it will allow me to add the "Premium Style"  photos from the gallery to the collection whether or not they have purchased the upgrade fee from the new price list attached to the "Premium Style" photo(s) in that gallery. 

My 2nd Issue:  When I'm logged in as a client and first add the "Premium Style" upgrade fee and package from the "Premium Style" shopping cart/price list I cannot add any photo to that collection whether or not it is a "Premium Style" or "Traditional Style" photo.  I get a red box that says "Sorry, this photo is not available for your collection."

I have upgraded to the most recent available version as of this morning.  I'm just not exactly sure what to do to correct this issue.

Thank you in advance for your help!

Lori Seals - Lori A. Seals Photography
433 posts
Tue Dec 05, 23 9:32 AM CST
Lori Seals wrote:

A couple of things I just noticed. . .

I sell "Traditional Style" and "Premium Style" photos to my clients.  The "Premium Style" photos have a different price list attached to them and prompt for an upgrade fee to be added to their shopping cart first before it unlocks the "Premium Style" shopping cart/price list in their gallery.  

My 1st Issue:  When I'm logged in as a client and add photos to a "Traditional Style" collection in a gallery it will allow me to add the "Premium Style"  photos from the gallery to the collection whether or not they have purchased the upgrade fee from the new price list attached to the "Premium Style" photo(s) in that gallery. 

My 2nd Issue:  When I'm logged in as a client and first add the "Premium Style" upgrade fee and package from the "Premium Style" shopping cart/price list I cannot add any photo to that collection whether or not it is a "Premium Style" or "Traditional Style" photo.  I get a red box that says "Sorry, this photo is not available for your collection."

I have upgraded to the most recent available version as of this morning.  I'm just not exactly sure what to do to correct this issue.

Thank you in advance for your help!

sounds like you have the same collection in each price list, and you selected not to allow photos from a different gallery to that collection(s) best to show screen shots of your setups.

26 posts
Tue Dec 05, 23 9:49 AM CST

I have "Premium Style" Collections that are in a "Premium Style" Price List and then I have "Traditional Style" Collections that are in a "Traditional Style" Price List, so the same collection is not in each price list.  I have a feeling that there is a simple solution to this, but I'm having trouble figuring it out on my end.  

Each gallery is automatically set to the "Traditional Style" Price List with some of the photos in the gallery that are set to the "Premium Style" Price List. With the "old" way when a client would click/tap on one of the "Premium Style" photo(s) in their gallery the "Premium Style" shopping cart would pop up and ask for the upgrade fee first and then that would unlock the "Premium Style" shopping cart so they can proceed with their order. 

I'm not sure screenshots would help me explain this any better and I'm not sure what I would even show in the screenshots that would help me support what's going on any better.

Lori Seals - Lori A. Seals Photography
433 posts
Tue Dec 05, 23 1:06 PM CST

Then you do not have your premium price list category set to "check Require a selection from this group before the can select products from other groups" or you did not save once you made the price list change in the admin photo section. See price list set up sample pic

Attached Photos

433 posts
Tue Dec 05, 23 1:11 PM CST

But it will still allow all the photos in a gallery to be added to a collection even in the traditional price list. You would have too have another gallery and do not allow pics to be added to the collection selected. This is has always worked this way.

26 posts
Tue Dec 05, 23 1:17 PM CST

Yes, I have that box checked in the "Premium Style" price list that requires the upgrade fee to be added first before anything else can be added from the "Premium Style" cart (Premium Style collections & prints/products).

This is how my setup has always been with my galleries...The gallery is set to a "Traditional Style" price list.  Each gallery contains "Traditional Style" & "Premium Style" photos in it. The "Premium Style" photos are manually selected by me and their price list is changed to my "Premium Style" price list.  My "Premium Style" price list requires my client to add the upgrade fee first before the "Premium Style" price list is unlocked to add their collections and prints/products.


I hope that makes sense.
Edited Tue Dec 05, 23 1:17 PM by Lori Seals
Lori Seals - Lori A. Seals Photography
16,043 posts (admin)
Tue Dec 05, 23 1:22 PM CST

I am working on it. One issue caused by another. 

Tim Grissett, DIA - PicturesPro.com
My Email Address: info@picturespro.com
26 posts
Tue Dec 05, 23 1:25 PM CST

Thank you, Tim!!  It's greatly appreciated!!


UPDATE 12/06:  Everything works perfectly now, Tim.  Thank you again for all of your help.  I absolutely love the upgrade and I know my clients will too!  

Edited Wed Dec 06, 23 8:09 AM by Lori Seals
Lori Seals - Lori A. Seals Photography
M
46 posts
Mon Jan 29, 24 4:19 PM CST

Hi Tim, 

I have been testing the new password loading where Sytist creates the passwords.  If I use this and use Extra 1 as the child's name is there a way to have the email send the child's name in the email next to the password?  This would be helpful if a parent has more than 1 child.   

Also going forward will there be the option to be able to go into the Peoples tab for a gallery and text a reminder to everyone that hasn't ordered.  

Thanks

16,043 posts (admin)
Tue Jan 30, 24 6:39 AM CST

It is not possible to add the child's name next to the password but will show the passcodes for each child. 

I don't know when a text option will be available for that.

Tim Grissett, DIA - PicturesPro.com
My Email Address: info@picturespro.com
33 total messages
Please log in or Create an account to post or reply to topics.
This post has been viewed 792 times
Category: Other
 
Loading more pages
Loading more pages

Sign up for email promotions.

Your information is safe with us and won't be shared.

Thank you for signing up!

 
©2003 - 2021 Grissett, LLC. All Rights Reserved.

By continuing to browse or by clicking Accept Cookies, you agree to the storing of cookies on your device necessary to provide you with the services available through our website.

    Accept   Privacy & Cookie Policy
Loading More Photos
Scroll To Top
Close Window
Loading
Close