Attention

If your Photo Cart is suddenly getting a 500 error or only displaying a blank page then you or your hosting company has updated the PHP (programming language) to PHP 7 which Photo Cart is not compatible with (and will not be compatible with) mainly because of the removal of the my_sql functions which are replaced with my_sqli functions. 

You would need to have the PHP version downgraded to 5.6 in order for Photo Cart to work. If downgrading the PHP doesn't work then you may have to update Photo Cart to the last version of 7. Download Photo Cart 7 upgrade files. Upgrade instructions.

Photo Cart was retired in 2015. Check out Sytist.

Please log in or Create an account to post or reply to topics.
You will still receive notifications of replies to topics you are part of even if you do not subscribe to new topic emails.

Can't Update Php For My Site Without Photo Cart Error

C
10 posts
Mon Nov 11, 19 8:32 AM CST
My Wordpress needs a PHP update in order to function properly. When I update to a higher PHP version, my Photo Cart gets an error message. I am not comfortable with updating and don't even know what PHP is.


Warning: Use of undefined constant utf8_encode - assumed 'utf8_encode' (this will throw an Error in a future version of PHP) in /home/emapho5/public_html/proofs/pc_inc/functions.core.php on line 227

Warning: Use of undefined constant photoCartIncluded - assumed 'photoCartIncluded' (this will throw an Error in a future version of PHP) in /home/emapho5/public_html/proofs/admin/admin.icons.php on line 1

Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /home/emapho5/public_html/proofs/pc_inc/functions.core.php:9 Stack trace: #0 /home/emapho5/public_html/proofs/admin/manage.php(13): dbConnect(Array) #1 {main} thrown in /home/emapho5/public_html/proofs/pc_inc/functions.core.php on line 9
16,196 posts (admin)
Tue Nov 12, 19 5:08 AM CST
Photo Cart is not compatible with PHP 7 and won't be. In order to use Photo Cart the PHP version has to be PHP 5.

PHP is the programming language.
Tim Grissett, DIA - PicturesPro.com
My Email Address: info@picturespro.com
C
10 posts
Tue Nov 12, 19 1:25 PM CST
So is there a work around?
16,196 posts (admin)
Wed Nov 13, 19 5:48 AM CST
No. Photo Cart will NOT be compatible with PHP 7.

There is a newer product Sytist which is compatible with PHP 7.
https://www.picturespro.com/sytist/
Tim Grissett, DIA - PicturesPro.com
My Email Address: info@picturespro.com
C
10 posts
Thu Nov 14, 19 8:41 PM CST
Thanks Tim...been with photo cart since the beginning and the thought of not just spending more $ on a new program but learning it stresses me out. I feel like I spent so much time customizing my photo cart with my pricing and packages that it would be so much work starting over.
5 total messages
Please log in or Create an account to post or reply to topics.
This post has been viewed 1,371 times
Category: Error
 
Loading more pages
Loading more pages

Sign up for email promotions.

Your information is safe with us and won't be shared.

Thank you for signing up!

 
©2003 - 2021 Grissett, LLC. All Rights Reserved.

By continuing to browse or by clicking Accept Cookies, you agree to the storing of cookies on your device necessary to provide you with the services available through our website.

    Accept   Privacy & Cookie Policy
Loading More Photos
Scroll To Top
Close Window
Loading
Close