If you have a support question or comment, click the Post New Topic link below. Sytist Manual | Sytist Articles | Facebook Page.

Sytist 0.7.7 Update Now Available - Updated 6 / 6 / 2014

 
Please log in or Create an account to post or reply to topics.
 
Tim - PicturesPro.com
admin
Mon Jun 02, 14
1:06 PM
Updated June 6, 2014 7:45 AM CST

I have updated the Installation / Upgrade files with a few fixes.
* Fixed error at checkout losing session information when PHP register globals are set to on.
* Fixed thumbnail page navigation not showing in some cases.
* Fixed the occasional tiny photo on first click from a gallery


--------------------------------------------------------------------------------------------------------------------------------------------

Hey Peeps, a new update is available with a bunch of stuff.

Something important to point out in this update is a rotate option when uploading photos. By default it is selected which means it works the same as in the previous version. But if you had issues with rotating photos in previous versions, then you really need to test uploading at least one portrait and one landscape oriented photo before upload a bunch to test the new rotate option and see if you need it checked or unchecked.

Here are some highlights (complete change log here)


  • Changed up the way the photo data is gathered in the thumbnail galleries and now not limited to the amount of photos you can put in one gallery.

  • Added an option for a next / previous page of thumbnails after so many photos (Settings -> Photo Sizes & Defaults)

  • Added an option to replace photos

  • Added an option for downloads to not allow immediate download of photo until you replace the photo or allow them to

  • Added an option when uploading or processing photos to check for rotation or not (before uploading a bunch of photos, test uploading at least one portrait and one landscape oriented photo to test this and see if you need it checked or unchecked.)

  • Added the function when adding a collection that only contains 1 pose, it automatically populates the collection with the photo they are viewing for all products included in the collection.

  • Added an option to send new order email notifications to a different or multiple email addresses (Settings -> Admin / Main Settings).

  • Added the option to create invoices without an account. (Order -> Create Invoice).

  • Added the option to create a header & footer for emails (Settings -> Default Emails).

  • Added an option to find photos in a gallery by time blocks (photo display settings).

  • Added the option to delete shopping carts from admin in (Stats -> Shopping carts)

  • Added an option in dropdown options in collections set to "Making selections only" to have the option determine how many photos are selected.

  • Added an option for "Do not display sub galleries" when a page has sub galleries.

  • Added when many download photos on an order, create multiple zip files to be downloaded. The max setting is in (Settings -> Photo Sizes & Defaults).

  • Added a quality value for when uploading photos

  • Added the ability when viewing photos in a sub gallery in the admin, to select from the preview photo icon to make photos preview photo for the sub gallery or main gallery.

  • Added an option in store options for date .



Here is a link to the change log with the complete list of changes:
http://www.picturespro.com/sytist-manual/change-log/change-log/

And how to upgrade:
http://www.picturespro.com/sytist-manual/installation/upgrading/

I feel like I am forgetting to do something ...............


Edited Fri Jun 06, 14 7:47 AM by Tim - PicturesPro.com
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
a badger
Mon Jun 02, 14
9:05 PM
Thank you Tim, you always consider requests, it is appreciated.
Jamie Elle
Mon Jun 02, 14
10:27 PM
that quantity issue that I had with my books... was that addressed?
a badger
Mon Jun 02, 14
11:17 PM
Hi Tim,
Thank you for adding the option I had requested....
Added an option for downloads to not allow immediate download of photo until you replace the photo or allow them to
Is there a way to use this with an image package or will it automatically do this?
Tim - PicturesPro.com
admin
Tue Jun 03, 14
7:37 AM
Jaimie, "Added an option in dropdown options in collections set to "Making selections only" to have the option determine how many photos are selected."

This should do what you need. You can use it like an option for 8 pages, then select 8 photos, 12 pages, 12 photos, etc ....

a badger, if the product in the product base is using this option, it will also work if the product is in a package.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Sean Molin
Tue Jun 03, 14
1:24 PM
MONSTER update. Thank you so much. I have been waiting patiently for the header/footer e-mail option before getting to deep into customizing them.

And the download replacement feature is brilliant and very welcome.
 
 
 
 
 
Sean Molin Photography ? www.seanmolin.com | concART Live Music Photography ? www.concART.net
paul
Wed Jun 04, 14
9:31 AM
Hi Tim,

With the replace photos option, will it regenerate the thumbs and mid sized images??

Do you have any plans to add the old photocart feature to simply go to the gallery and have the option to re-generate thumbs and/or midsized? Would be really useful if you change the default photo sizes etc....

Thanks
Tim - PicturesPro.com
admin
Wed Jun 04, 14
10:17 AM
The replace function will replace all files of that photo (all sizes).

That is a maybe on the regenerate photo sizes.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Guy A
Wed Jun 04, 14
10:48 AM
Thank you!

Not sure if I missed it or not - did you add in being able to link directly to an image within a gallery? As opposed to the preview of that image?
Arron Robles
Wed Jun 04, 14
11:44 AM
New release looks great. Hats off to you again Tim.
 
 
 
 
 
Arron Robles, Solutions Designer |Reports Developer | SharePoint Developer - APVisions.com - arron@apvisions.com | PicturesPro Affiliate | Sytist V.2.4.0 | PhotoCart V.7.1.0
Tim - PicturesPro.com
admin
Wed Jun 04, 14
11:56 AM
Guy, now when viewing photos in a gallery, it uses a hash (like mysite/clients/gallery/#photo=sdsd7sif7di3334w7df ) So you can copy that out of the address bar and it will link directly to that photo.

I need to update the demo so I can show you, but I have been having DNS issues the last couple of days.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
paul
Wed Jun 04, 14
1:23 PM
You really need a quoting feature in here :)

Just another point on the regeneration. If you change your water mark you'd have to re-upload everything again to get it on there....

$ du -h --max-depth=1 sy-photos/
5.9G sy-photos/order-photos
8.0K sy-photos/zips
449G sy-photos/2014
908K sy-photos/watermarks
356K sy-photos/sample
455G sy-photos/
$

Not a fun task for 455 gigs of photos....
Sean Molin
Wed Jun 04, 14
6:30 PM
Anybody else have 0.7.7 break their checkout? After updating when you try to place an order, instead of a confirmation or order placement it just goes to a screen with a red bar that says "your shopping cart is empty". I've tried with both Stripe/CC and Offline (mail a check). I've also upgraded many times with no issues. I even "re-upgraded" just to be safe.

I sent a support request to Tim already, but I wanted to see if anyone else is having or has had this issue.
 
 
 
 
 
Sean Molin Photography ? www.seanmolin.com | concART Live Music Photography ? www.concART.net
Chris Nutt
Thu Jun 05, 14
3:19 AM
Also just noticed ( a customer pointed it out in fact) that a number of photo had "disappeared" from the ends of our galleries. It turned out to be the new default setting of 200 for the number of thumbnails displayed - accessible in Settings > Photo Sizes and Defaults. I do keep the numbers well below the 400 as previously recommended, however I hadn't noticed this new default setting. Resetting to 400 has solved the issue.
 
 
 
 
 
Chris Nutt
Thu Jun 05, 14
3:25 AM
I have the same problem as Sean Molin. Added a couple of items to my own cart - then tried to checkout - and the red "Your Shopping Cart is empty" warning pops up - but on checking the cart then items are there. Help!!
 
 
 
 
 
Chris Nutt
Thu Jun 05, 14
3:30 AM
OK - in follow up to the previous note re the empty shopping cart issue - It seems to be related to using to the "view my website" and being "automatically" logged in. If I log out - than log back in again the shopping carts seem to work properly.
 
 
 
 
 
Tim - PicturesPro.com
admin
Thu Jun 05, 14
6:17 AM
When you guys are going to the checkout page, notice and see if the URL is changing between using the www. and not using the www.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
paul
Thu Jun 05, 14
9:48 AM
Check out works fine for me.

I do have have one other issue with the placing of orders.

I have PayPal Standard enabled as well as 2 offline payment methods.

If they pay with the offline methods and complete the order, there still shows a button in the "index.php?view=order" page that takes you to PayPal...

Shouldn't that be removed for offline payments? It might be helpful to perhaps give the customer options to change their payment method after the order.
Chris Nutt
Thu Jun 05, 14
10:18 AM
Hi Tim,

As we have a SSL checkout system, I can confirm that when going to checkout the URL changes from our normal www.codsall....... to https://secure56/prosite....etc (which is our free SSL site reference)

Also regarding the limit to the number of thumbnails - I'm note sure if i'm being a bit blind, but I can't see the option to have a "go to next page" option on the "Photo setting and Defaults" screen - and nothing is visible on the galleries from the customer side.
 
 
 
 
 
Sean Molin
Thu Jun 05, 14
10:43 AM
Everything goes to https just fine. When placing the order, it stays in https but says "the shopping cart is empty" but no order is placed and the cart doesn't actually empty.

When logged in as admin I can't even add anything to the cart anyway. I did all these tests as an actual customer account logged out of admin.
 
 
 
 
 
Sean Molin Photography ? www.seanmolin.com | concART Live Music Photography ? www.concART.net
Tim - PicturesPro.com
admin
Thu Jun 05, 14
12:33 PM
I have Sean fixed so Chris, re-download the upgrade files and re-upload the sy-inc folder.

What it is was a new thing added was to update the account information on checkout. Well it appears that if the PHP register_globals are on on your hosting account (which most hosts have it off) it was overwriting a session variable and causing the issue.

[p]Paul[/b], the pay now button for offline payments is there if they change their mind and way to pay online.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
paul
Thu Jun 05, 14
2:14 PM
Ok Thanks. Figured as much. Perhaps you can make it stand out a bit more as the alternate payment method?
paul
Thu Jun 05, 14
4:34 PM
I'm seeing the problem where there is no NEXT on the gallery pages. I've bumped it to 400 but unfortunatly some of my galleries are lager than that.

Can you please let us know how to disable this feature?
Tim - PicturesPro.com
admin
Fri Jun 06, 14
7:48 AM
Updated June 6, 2014 7:45 AM CST

I have updated the Installation / Upgrade files with a few fixes.
* Fixed error at checkout losing session information when PHP register globals are set to on.
* Fixed thumbnail page navigation not showing in some cases.
* Fixed the occasional tiny photo on first click from a gallery


If you installed 0.7.7, you can re-download the upgrade files and just re-upload the sy-inc folder to apply the fixes above.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
paul
Fri Jun 06, 14
7:50 AM
thanks Tim.
Chris Nutt
Sat Jun 07, 14
10:56 AM
Thanks Tim, issues solved! the "next" box is now showing at the end of the gallery pages.
 
 
 
 
 
Rebecca English
Mon Jun 09, 14
2:35 PM
Hi, Tim! I just installed the 0.7.7 upgrade today, and I really like the features, but I'm having a huge problem uploading client files to the proofing section. It will not allow me to upload more than one file to the gallery when watermarking is enabled (and I have a couple hundred files to upload today!) Is there a quick fix to this? Thanks!
Tim - PicturesPro.com
admin
Mon Jun 09, 14
3:21 PM
Are you getting a Select Photos button like in this screen shot:
http://www.picturespro.com/sy-misc/adding-photos-to-a-page/20140416090856-uploading-photos-2.jpg

Or are you seeing a file or browse button instead? If so, then flash might not be installed on your computer or enabled in the browser.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Rebecca English
Mon Jun 09, 14
6:08 PM
No, my upload screen looks like this:
Attached Photos
Rebecca English
Mon Jun 09, 14
6:09 PM
I can upload multiple pictures when I don't select the watermarking feature, but not when it is selected.
Tim - PicturesPro.com
admin
Tue Jun 10, 14
8:26 AM
Does it just stop uploading or something when you select to watermark, or is it just only letting you select one?

Have you uploaded your own watermark, and if so, what is the dimensions of it? It may be too large.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Rebecca English
Tue Jun 10, 14
9:15 AM
It's only letting me select one file at a time. I have uploaded my own watermark, and it is a 600x600 png, with a file size of 146k.
Tim - PicturesPro.com
admin
Tue Jun 10, 14
10:52 AM
Can you email me a link to your admin with the username and password so I can take a look at it?

info@picturespro.com
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Rebecca English
Tue Jun 10, 14
11:13 AM
Just sent the info. Thanks for all your help!
Rob Sigler
Thu Jun 12, 14
8:55 AM
Hey Tim...AWESOME update. I too am only able to select one photo at a time when uploading. Any help is appreciated!

Rob Sigler
Tim - PicturesPro.com
admin
Fri Jun 13, 14
5:43 AM
Re-download the upgrade files and re-upload them. I added a fix to the files for that a couple of days ago.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Rob Sigler
Wed Jun 18, 14
10:47 AM
Hey Tim,

I just re-downloaded the upgrade, and I can still only select one file at a time. Thanks for any help.

(On a mac, with safari.)

Rob
Rebecca English
Wed Jun 18, 14
12:24 PM
Hi, Tim! I upgraded to Sytist 0.7.7 last week, and now I'm having problems with my clients logging into their galleries. Although I disabled the password prompt when I set up the CMS, it still prompts for a password. And it won't tell me what the password is, so the client can't access the pictures. I tried to change the password, but although it says it updated, the password does not appear to change. I also tried changing the password to the CMS, but it won't allow me to change that either. You can see what it's doing here: http://proofing.sandpiperphotography.com/proofing/brittany-and-seth/

Please help!!!! Thank you!
Rebecca
Tim - PicturesPro.com
admin
Wed Jun 18, 14
2:32 PM
Rebecca, click on Settings in the main menu, then down the left menu click Site Password. You have a password set there which password protects the entire site.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Chris Nutt
Wed Jun 18, 14
4:08 PM
Hi Tim. Just had a customer complaint that they are getting the "shopping cart is empty" problem again when going to checkout. Tried logging in as them myself and I see the issue too. I thought this had been fixed with the sy-inc folder updates. Also tried this wih another customer with a shopping cart and seeing the same issue there too.

I am using an SSL checkout system.


Thanks in advance.
 
 
 
 
 
Tim - PicturesPro.com
admin
Thu Jun 19, 14
6:10 AM
Chris, look in the address bar and see if it is swapping from www.yourdomain to just yourdomain (or the other way around). And for your SSL setting in Settings -> Checkout & Payment, do you have a link in the SSL section?
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Chris Nutt
Thu Jun 19, 14
2:55 PM
Hi Tim

When going to checkout (and the cart is reported as empty) the address bar goes from

http://www.codsallphotographic.com/sytist1/index.php
to
https://secure56.prositehosting.co.uk/sytist1/index.php?view=checkout (This is the SSL address required as it is a shared certificate)

The top line also shows "Log in" as if the customer has logged out.

If I log in as a dummy user and create an order it also shows cart empty when checking out (and log-in shows on the top line) - but if I then log in again - it lets me check-out. In both cases the addresses are the same on the check-out page.
 
 
 
 
 
Chris Nutt
Thu Jun 19, 14
3:07 PM
Also just tried re-uploading the updated 0.7.7 sy-inc folder - but no difference made.
 
 
 
 
 
Chris Nutt
Thu Jun 19, 14
4:50 PM
Tim,
As this is currently losing us sales, i have removed the SSL system and the collect payment info option. Will re-instate when issue can be solved.
 
 
 
 
 
Gabrielle Mappone
Fri Jun 20, 14
6:41 AM
Thanks, TIm!
Not to sound greedy, but I would love for the ability to upload and have the program resize them for me. I prefer to just export once to my finished size, but the images are always too big for this and I have to export again.
Chris Nutt
Sat Jun 21, 14
11:01 AM
Hi Tim,

I'm still having problems with the secure SSL checkout. If I switch off the SSL option In "Checkout and Payment options" - all works fine - and the customer goes straight through to the checkout system. As soon as I turn on the SSL option, the checkout says "Your shopping cart is empty" and does not work unless the customer logs in again (and of course it's not obvious they need to do that).
My SSL certificate is installed on the sub-folder where Sytist is installed - not in the root. https://secure56.prositehosting.co.uk is the address pasted into the SSL box In "Checkout and Payment options"

This is strange - as I had the exact same problem on the initial release of 0.7.7 - and then it went away after you personally updated my files - and did not re-appear after the upgrade to the updated 0.7.7 - but appeared sometime later (first note of the issue was a customer complaint earlier this week - and a number of orders had come through OK before that point) I hadn't changed anything on the system (to my knowledge)

As mentioned above I have (for now) switched off the SSL check box and removed the payment option requiring SSL as i don't want to lose any more sales.

Thanks in advance for your assistance.
 
 
 
 
 
Tim - PicturesPro.com
admin
Mon Jun 23, 14
6:25 AM
Chris, did using the https://secure56.prositehosting.co.uk i URL work previously? I can't imagine it did because it is basically switching domains and then losing the cookie of the customer (which is tied to the domain). Can you not have your domain as the SSL url?

Instead of replying here, send me an email to info@picturespro.com with your reply.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
pierre chiha
Sun Jun 29, 14
5:14 PM
Hi Tim,
Any change you will add the option to add a photo to show what a product looks like. I sell different styles of albums, metallic prints, Acrylic blocks, different mounts for canvas prints, and it would be great to be able to show my clients what those things look like.
Thanks for considering it.
Pierre
Gabrielle Mappone
Sun Jun 29, 14
5:17 PM
Pierre....I photographed my samples and was able to upload them. In the collections section, I listed the items and posted photos. If I have options, I uploaded photos of all of them and added text over the image to explain what it was.

Just an idea ;)
pierre chiha
Sun Jun 29, 14
5:21 PM
Hi Gabrielle (that's my daughter's name!). Is it possible to see how you did it on your website? And that solution implies that the customer is going to go to the collections section as opposed to just ordering a la carte, doesn't it? Thanks
Gabrielle Mappone
Sun Jun 29, 14
5:28 PM
Nope. My clients all order al a cart. I added products to collections and then add them to the price lists. I have no packages listed. I am still organizing this. But I created a collection, added photos and then added it to the price lists. I don't know how many photos I am limited to yet.
Tawana Cox
Wed Jul 02, 14
1:21 AM
I just upgraded, and now its showing an odd error message below the photos on the homepage:
Warning: Division by zero in /home/content/64/11067664/html/sy-inc/photos_nextprevious.php on line 107

How do I remove this?
This reply was deleted.
Tim - PicturesPro.com
admin
Wed Jul 02, 14
10:25 AM
Sounds like you didn't upload ALL the files and folders from the upgrade folder. Re-upload the upgrade files and be sure to select all and upload.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Tawana Cox
Wed Jul 02, 14
11:07 PM
Hello,
I REuploaded all the files a second time and still am getting the same error message.

Thank
Tim - PicturesPro.com
admin
Thu Jul 03, 14
6:54 AM
Tawana, you may want to email me a link to your Sytist installation and your FTP username and password so I can look into it and upload the files.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
This reply was deleted.
Chris Nutt
Sat Jul 05, 14
3:26 AM
When viewing shopping carts the photo is overlapping the text description. See attached screen grab. Is there any way to overcome this?
Attached Photos
 
 
 
 
 
Tim - PicturesPro.com
admin
Mon Jul 07, 14
4:45 AM
Where are you viewing this? In the admin? Or on the customer side?
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Chris Nutt
Mon Jul 07, 14
9:12 AM
Hi Tim,

Strangely enough, it's not doing it now. I'll see if I can replicate it and find the route to the cause.
 
 
 
 
 

Loading more pages
Sign up for email promotions.
Your information is safe with us and won't be shared.
Thank you for signing up!
 
©2003 - 2017 Grissett, LLC. All Rights Reserved.
Loading More Photos
Scroll To Top
Close Window
Loading
Close