To post a new support question, click the Post New Topic button below.
Current Version: 4.6.0 | Sytist Manual | Common  Issues | Feature Requests

Please log in or Create an account to post or reply to topics.
You will still receive notifications of replies to topics you are part of even if you do not subscribe to new topic emails.

Particular Access Code Not Working

C
125 posts
Sun Sep 17, 23 6:07 AM CST

I created a gallery in preparation for an event yesterday together with a unique access code. The gallery was uploaded with photos today and set to publish. However the gallery is not accessible - "Gallery not found" comes up as the error message when entering the access code. The bug seems to be in the sequence of letters used - and after lots of experiments this morning I have found (by changing the access code on the gallery and then trying to access it):

The original code of sdreunion23 does NOT allow access

sdreunion does NOT allow access

sdreunio DOES allow access

sdreuniox DOES allow access

sdreuniox23 DOES allow access

sdreunio1234 DOES allow access

So, by adding the "n" on the end of "sdreunio" the system seems to not recognise the gallery. And it's clearly not the length or letters followed by numbers causing it. 

Never had this problem before - and i've been using Sytist since verion 1 (and it's previous incarnation)

Edited Sun Sep 17, 23 6:07 AM by Chris Nutt
T
324 posts
Sun Sep 17, 23 6:57 AM CST

There are certain words that are not allowed as passcode due to nefarious SQL code injection concerns.

I believe Union is one of them.

C
125 posts
Sun Sep 17, 23 7:06 AM CST

Thanks Trailboy. Can't find anything in the manual about it. Maybe it's buried in there somewhere!  However if this is the case, it would be useful if they could be disallowed when setting up the gallery! 


T
324 posts
Sun Sep 17, 23 7:15 AM CST

Perhaps that's intentional.  A check would be useful.


https://www.picturespro.com/support-forum/sytist/5...



Edited Sun Sep 17, 23 7:17 AM by Trailboy
C
125 posts
Sun Sep 17, 23 7:22 AM CST
Trailboy wrote:

Perhaps that's intentional.  A check would be useful.


https://www.picturespro.com/support-forum/sytist/5...



It would - as I do look a bit of a numpty in front of my customers this morning....  Looks like I need to manually check the validity in the future....

Edited Sun Sep 17, 23 12:16 PM by Chris Nutt
5 total messages
Please log in or Create an account to post or reply to topics.
This post has been viewed 60 times
Category: Bug
 
Loading more pages
Loading more pages

Sign up for email promotions.

Your information is safe with us and won't be shared.

Thank you for signing up!

 
©2003 - 2021 Grissett, LLC. All Rights Reserved.

By continuing to browse or by clicking Accept Cookies, you agree to the storing of cookies on your device necessary to provide you with the services available through our website.

    Accept   Privacy & Cookie Policy
Loading More Photos
Scroll To Top
Close Window
Loading
Close