If you have a support question or comment, click the Post New Topic link below. Sytist Manual | Sytist Articles | Facebook Page.

Client Gallery Password Not Working + Other Issues

 
Please log in or Create an account to post or reply to topics.
 
Paula Sword
5 posts
Fri Apr 27, 18
4:58 PM
Hello,

I moved to a new website a while ago, with Sytist still in the same directory (/client). The system appears to be broken.

Can make new gallery, but password doesn't work
Can remove password, but not re-enable password - just refreshes
Cant access galleries with password - just refreshes
Cant change password on galleries - just refreshes
Cant change gallery status to draft - just refreshes

http://photoheart.ca/client/

No recent errors in the error log.

I wasn't able to get into the admin at first, but saw a forum post about removing the two lines from sys-admin.php about the maxlifetime and phpsessions. That fixed the login, but still having issues.

I'm at a loss - can you help?
Tim - PicturesPro.com
9626 posts
admin
Sun Apr 29, 18
6:23 AM
I am going to guess either you don't have any space left on your hosting account or the host is using some sort caching service like Varnish, Cloud Flare or Site Lock which can cause similar issues. I would check those.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Paula Sword
5 posts
Sun Apr 29, 18
1:12 PM
Hello, thanks for the prompt reply. We certainly have server space, but we are running Varnish. Do you have any suggestions?
Tim - PicturesPro.com
9626 posts
admin
Mon Apr 30, 18
7:09 AM
See if Varnish can be disabled for the directory your Sytist is in.

Or you can try to edit the .htaccess file in your Sytist folder and add this line of code to the top of the file. It sometimes works.

Header add "disablevcache" "true"


 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Paula Sword
5 posts
Mon Apr 30, 18
7:35 PM
Looks like that was the fix I needed! Excluded Sytist directory from Varnish and most functionality seems restored. Checking the rest of it tonight.

Thanks so much Tim!
Paula Sword
5 posts
Wed May 02, 18
4:39 PM
Okay, turns out I spoke too soon - still having similar issues.

So I can now login and make changes to galleries and their passwords. However, entering galleries via password doesn't always work. I can get access occasionally, and get proper 'password incorrect' warnings, but I still see some of the 'refresh' behaviour when entering passwords.

I tried from incognito windows and from various browsers.

Any insight?

Thanks!
Tim - PicturesPro.com
9626 posts
admin
Thu May 03, 18
7:31 AM
You might need to have your host look into. Also make the modification to the .htaccess file I wrote above about.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Paula Sword
5 posts
Thu May 03, 18
10:34 AM
I did make the HTAccess tweak you've asked for, as well as ran a Varnish test to ensure it wasn't caching the page. I don't run a traditional host like GoDaddy, but on some independent web servers. I have direct access to the host and some moderate technical skill. Can you give me some advice on what I'm looking for?
Tim - PicturesPro.com
9626 posts
admin
Thu May 03, 18
12:21 PM
I really don't know what it would be if you have disabled Varnish. Post or email me a link to a gallery with the password so I can test it out.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Loading more pages
Loading more pages
Sign up for email promotions.
Your information is safe with us and won't be shared.
Thank you for signing up!
 
©2003 - 2017 Grissett, LLC. All Rights Reserved.
Loading More Photos
Scroll To Top
Close Window
Loading
Close