If you have a support question or comment, click the Post New Topic link below.
Current Version: 3.5.3Sytist Manual | Sytist Articles 

Shipping Not Being Passed Onto Paypal

 
Please log in or Create an account to post or reply to topics.
 
Vance Birno
83 posts
Mon Aug 12, 19
9:32 PM
Hi tim,
Been having a problem lately with paypal not getting the shipping info. Orders that do not have shipping are getting the "Ship" link on paypal and the orders that are to be shipped are not getting the "Ship " link. The shipping charge is not showing on the paypal transaction. They are telling me that is my sites problem and not theirs. Any ideas?
 
 
 
 
 
Tim - PicturesPro.com
11594 posts
admin
Tue Aug 13, 19
11:16 AM
If there are products being purchased that are to be shipped, it will send a shipping amount of 0.00 (Sytist does the shipping calculations, not PayPal ... PayPal is just taking the payment).

If there are no products being purchased that are shippable., then it sends the variable no_shipping = 1 ... meaning it does not need to do any shipping.

Don't know why it would be any different lately, it has always been like that.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Vance Birno
83 posts
Tue Aug 13, 19
1:00 PM
Thanks for thew response Tim, yes i understand how it is suppose to work, but it is not, Items being picked up or delivered by hand get the shipping link on pay pal, but orders being shipped do not get the link and the shipping cost is not being sent to paypal. I do not understand why either, nothing has changed on this end. see photos this was just the other day. I was talking to Paypal last night for about 30 minutes, they say the communication is coming in flip flopped. The pics are the same order.
Attached Photos

Edited Tue Aug 13, 19 1:01 PM by Vance Birno
 
 
 
 
 
Tim - PicturesPro.com
11594 posts
admin
Wed Aug 14, 19
11:30 AM
PayPal never adds a shipping cost (at least it shouldn't) because Sytist is calculating shipping before the payment.

So you are saying that now there is not a link in your PayPal account to ship the item and it was just recently there? I do see in your screenshot a message "We have no postal address on file". If you look at past payments where you did have shipping, do those say the same thing?
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Vance Birno
83 posts
Wed Aug 14, 19
1:03 PM
Ok lets forget about paypal not showing the shipping charge, but there is a problem with that too, they are charging a fee on that charge, thus my shipping is off and i loose money, they do not charge fees on shipping. But back to square one, items for pick up are generating the the ship link, and items to be shipped are not. What is the fix for this? is it Sytist or is it Paypal. It had been working fine until your last patch.(Removed developer files) This makes no sense at all why non shipped items are getting the ship link.



Thanks Tim,
Vance
 
 
 
 
 
Vance Birno
83 posts
Wed Aug 14, 19
1:59 PM
I believe the reason for "No shipping address on file" is they paid with a CC or debit card, and not thru a paypal account. might be worth having a API option instead of just using a email address associated with the account, never had this on my other site, but that may be because i used a API integration.
 
 
 
 
 
Loading more pages
Loading more pages

Sign up for email promotions.

Your information is safe with us and won't be shared.

Thank you for signing up!

 
©2003 - 2019 Grissett, LLC. All Rights Reserved.

By continuing to browse or by clicking Accept Cookies, you agree to the storing of cookies on your device necessary to provide you with the services available through our website.

    Accept   Privacy & Cookie Policy
Loading More Photos
Scroll To Top
Close Window
Loading
Close