If you have a support question or comment, click the Post New Topic link below. Sytist Manual | Sytist Articles | Facebook Page.

Sytist Update 1.2 Now Available

 
Please log in or Create an account to post or reply to topics.
 
Tim - PicturesPro.com
admin
Sat Apr 02, 16
5:11 AM
A new Sytist update, 1.2.0, was released today with some new features.

Some of the highlights are:

Gallery Exclusive Mode

Log in with Facebook

Gallery Owner

Photgrapher Favorites

Custom Gallery Icons

And a lot more! See the change long for all additions and changes

If you look at the demo, the first 3 galleries have Gallery Exclusive Mode enabled and custom gallery icons. Also login with Facebook is enabled in the demo.

If you have any questions to comments about this update, post them here.

How to update:
The first time each day you log into the admin it will check for the update. If you have already logged into your admin today , then you won't get the notice until tomorrow.

If you are currently using version 1.0.0, you can have it check for the update again by clicking on Settings in the main menu. Then scroll down and below the left menu, click MySQL query. Copy the following line of code, paste it in the query box and click run.

UPDATE ms_history SET upgrade_check='';

Then return to your admin home page.

If the auto update feature won't work for you for some reason, you will have to manually update.
Edited Sat Apr 02, 16 5:31 AM by Tim - PicturesPro.com
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
andrew bershaw
Sat Apr 02, 16
10:19 AM
Hi Tim, auto update did not show a new version when i opened the admin this morning? Is there a patch to fix this? Auto update is a great feature, and this is the first time it hasn't shown up?

Andy
Edited Sat Apr 02, 16 10:24 AM by andrew bershaw
 
 
 
 
 
Jim Whitesell
Sat Apr 02, 16
11:55 AM
Hey Tim,

I tried to update from 0.9.1 but it failed. The update notice did appear. Auto update doesn't work for me (it never gets past unzipping the file) so I have done manual updates in the past. I did the manual upgrade and after ftping the upgrade files only. Was getting 500 server errors with nothing showing up in the browser ( blank page).

I restored from a backup and the site was fine again - then I tried upgrading once more time with the same errors - blank page and 500 server error.
The apache log file looks like there was no request for an actual page:
[02/Apr/2016:10:11:28 -0600] "GET / HTTP/1.1" 500 20 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.110 Safari/537.36"

I've restored again, am still on 0.9.1 without issue.

Suggestions?
Tim - PicturesPro.com
admin
Sat Apr 02, 16
12:20 PM
Andrew I replied to your email.

Jim, it could be that the mysqli_* function is not enabled in the PHP on your server. The last update I made Sytist compatible with PHP 7 so all the mysql_ functions were changed to mysqli_ (notice the i).

Is that something you can check?
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Jonathan Nobach
Sat Apr 02, 16
3:28 PM
A huge thanks to Tim for this recent update, some of the best features yet! Log in with Facebook, Photographer Favorites and the check-boxes when managing customer's orders are awesome! Thanks again Tim, keep up the great work.
Robin Zimmer
Sat Apr 02, 16
7:07 PM
Tim, The update is not working for me. My current version is 1.1.1. If I try the update process I get to the end but the version remains at 1.1.1 and I still see the message to update to 1.2.
Jim Whitesell
Sat Apr 02, 16
8:53 PM
Tim, I recompiled Apache with mysqli added to php and the upgrade worked without a hitch. Thanks for your help!
Tim - PicturesPro.com
admin
Sun Apr 03, 16
6:15 AM
Thank you and you're welcome Jonathan.

Robin, I replied to your email about this.

That's great Jim.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Victoria Pe?afiel
Sun Apr 03, 16
12:27 PM
Hello Tim! Loving all the new features and especially the gallery exclusive mode.

When you have the time to do so, could you make sure to make all text snippets translatable? Currently, gallery exclusive icons on top of the page show in English only (Share, My account...) and they don't show under "page text" for translation.

Also Photographer Favorites is not translatable either :-/

Other than that I love it!!
Victoria

--- OK, forget about it. I just found where to change everything under Gallery Exclusive settings :P
Edited Sun Apr 03, 16 12:31 PM by Victoria Pe?afiel
 
 
 
 
 
Will Wenzel
Sun Apr 03, 16
11:39 PM
Tim, love the Gallery Exclusive mode, but now I'd love to use it for all our galleries, but could you give us an option to have the featured image fullscreen without minimizing the header? Or is there a way to do this already?
Tim - PicturesPro.com
admin
Mon Apr 04, 16
6:41 AM
There is something similar you can do. You can edit the section those galleries are in (edit under the section / category name in the left menu), click Design Options and check the option for "Display a masthead (1 billboard slide) of the first photo or cover photo on pages displayed in this section."

It not exactly like the one in gallery exclusive, but similar.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Todd Bertrand
Mon Apr 04, 16
8:54 AM
Tim,

I am getting the following error when I attemtp to upgrade.

Fatal error: Class 'ZipArchive' not found in /home/avalonph/public_html/sy-admin/sytist-update.php on line 61
Tim - PicturesPro.com
admin
Mon Apr 04, 16
9:21 AM
That error means the Zip functions are not enabled in the PHP configuration on your hosting. You will either need to have your host enable the PHP zip extension, or you will have to manually update.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Todd Bertrand
Mon Apr 04, 16
9:42 AM
Tim,

Can the php zip extension be enabled through Cpanel like myphpadmim or is this more at the sever level? I have a dedicated server and I am not seeing how to enable zip functions.
Tim - PicturesPro.com
admin
Mon Apr 04, 16
10:19 AM
I don't know Todd. You may be able to enabled it through the php.ini file, but not sure if PHP has to be compiled with it.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Todd Bertrand
Mon Apr 04, 16
10:25 AM
Tim,

I have it figured out. For those with a dedicated server you have to go to Apache or Easy Apache and usually the advanced options. Scroll down and select Zip and rebuild Apache. This is not in Cpanel! It is is the base server configuration. Thanks Tim
ewood
Tue Apr 05, 16
1:30 AM
Hi guys,

In the Gallery exclusive Mode and free downloads option when customers download the gallery original size the zip is created fairly quickly however when selecting a reduced size downloading the gallery zip they get "waiting for yourwebsite.com" then after a few minutes a blank page opens up and stays open indefinitely with this address https://www.yoursite.com/sy-inc/store/store_download_free_zip.php"

Ed
Tim - PicturesPro.com
admin
Tue Apr 05, 16
7:01 AM
When downloading a reduced size, those photos have to be resized while putting in the zip, so it takes more resources.

In Settings -> Photo Settings, you can try to reduce some the number of photos per zip file value.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
ewood
Tue Apr 05, 16
9:16 AM
Thanks Tim,

Do you think its my server not being able to handle it I was testing only 12 files original size is 6000x4000 10-15MB each trying to take them down to 2048x. If it's the server not being powerful enough what requirements do you think I need to process up to 100 images.

Ed
Tim - PicturesPro.com
admin
Tue Apr 05, 16
12:35 PM
The server would have everything to do with it. I just tested on one of my dedicated servers having 25 10MB photos getting resized to 1600 pixels into a zip file and it worked. But it couldn't process 30 of them.

I don't know the specs of the server. Its about a year old and I know it's really good. But also for a dedicated server you will end up spending $200 - $400 per month.

If you are looking for another host, you could check into a virtual private server which won't cost as much.

But I would try to get the photos smaller than 15MB. I wouldn't think they would need that large of a file unless printing for a billboard.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Lachlan Ryan
Sat Apr 09, 16
8:16 AM
Hi Tim,

I mentioned previously that it would be good to use star ratings or keywords to identify photographer favourites (but doing this as part of the Lightroom workflow before photos are brought into Sytist). Well, you know how under 'All Photos' you can search by tags etc. Being able to do the same search within a particular page would be handy. Then by tagging photos with a simple keyword like 'favourite' I could quickly search and identify them and make them Favourites in Sytist. Unfortunately right now I can't go through thousands of photos (for big events) and make use of the feature. I just thought I'd flag this idea again in case it might be useful for others as well.

Cheers,
Lachlan.

P.S. Awesome features...I'm really glad I signed up for this software and love the continuous improvements.
Edited Sat Apr 09, 16 8:17 AM by Lachlan Ryan
 
 
 
 
 
Kelly Oostenbroek
Mon Apr 18, 16
12:59 AM
Hi guys,

I've been having the same error with my update (Fatal error: Class 'ZipArchive' not found...). After unsuccessfully trying everything that my hosting company suggested, I turned to Easy Apache. I checked the 'Zip' section and rebuilt apache - the update finally got past the error and looked like it started to work but before it finished the last step, the site went down. Any advice??
Tim - PicturesPro.com
admin
Mon Apr 18, 16
7:06 AM
It may have something to do with permissions or the database connection string.

Email me your FTP username and password so I can take a look.
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com
Jennifer Henry
Fri May 20, 16
6:15 PM
I did the manual update transferring the upgrade files via FTP, but it still shows the old version when I login to Admin. Any suggestions?

Thanks,
Jenn
Tim - PicturesPro.com
admin
Sat May 21, 16
7:52 AM
Sounds like you have your Sytist admin folder named something other than sy-admin and didn't upload the admin files into your admin folder.
https://www.picturespro.com/sytist-manual/installation/upgrading/
 
 
 
 
 
Tim Grissett, DIA - PicturesPro.com || My Email Address: info@picturespro.com

Loading more pages
Sign up for email promotions.
Your information is safe with us and won't be shared.
Thank you for signing up!
 
©2003 - 2017 Grissett, LLC. All Rights Reserved.
Loading More Photos
Scroll To Top
Close Window
Loading
Close